Poland Server is DOWN
Incident Report for LimeProxies
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 15:40 UTC
Identified
The Poland Server is DOWN. The issue is currently being worked on by our higher specialists and should be resolved within the next few hours.
Posted Sep 22, 2021 - 13:56 UTC